Back to overview
Resolved

Excel & Outlook plugins can't be installed

Aug 3, 2026 at 10:29am UTC
Affected services
app.langdock.com

Resolved
Aug 3, 2026 at 3:29pm UTC

Langdock for Excel and Langdock for Outlook can be installed again from within the desktop or web Excel and Outlook clients.

Created
Aug 3, 2026 at 10:29am UTC

Langdock for Excel and Langdock for Outlook are currently unavailable for new installations. Existing installations continue to work as expected. The issue also appears to affect other plugins in the Microsoft Marketplace.

We’re investigating the issue and monitoring Microsoft’s status page for updates:
https://status.cloud.microsoft/m365